SIEMENS, DF&PD

Предыдущее посещение: Сб фев 20, 2016 16:54 Текущее время: Сб фев 20, 2016 16:54

Часовой пояс: UTC + 3 часа




 [ Сообщений: 9 ] 
Автор Сообщение
 Заголовок сообщения: Конфигурирование приводов для 802D
СообщениеДобавлено: Пт фев 17, 2012 16:53 
Не в сети

Зарегистрирован: Пт фев 17, 2012 16:01
Сообщения: 6
Здравствуйте!

Имеется токарный станок СА983С10Ф3 2002 г/в с Sinumeric 802D (не SL).
Вместе с программами обработки станок потерял конфигурацию оборудования.

При настройке шины ProfiBus возникла проблема.

Адресация приводов сохранилась SP - 10, X- 20, Z - 21.

В родной документации от станка для параметра MD 11240 указано лишь два параметра 3 и 4. Адреса у этих параметров совсем другие. 10, 11, 12 или 10, 12, 13.
12 или 13 - адрес двухосевого привода. А в станке все привода одноосевые.
Тот привод, которому достается двухосевой адрес не отвечает. Ошибка непостедственно на приводе 0хА830 (если мне память не изменяет, сейчас уже не за станком)

В остальном ошибок при загрузке нет. Просто ожидание недостающего привода. Либо X либо Z.

Можно еще заложить параметр MD 11240 = 5, для него согласно другой версии документации адреса подходят: 10, 20, 21.
Но в данном контексте отказывается работать Profibus. PCU ругается на все начиная с PLC и заканчивая Profibus, включая все привода. А привода ругаются на потерю синхронизации данных.

MD 11240 = 6 не берет.

Такое чувство, что кроме адресации меняется еще и скорость передачи.

Profibus прозвоненый, живой.
Привода SinoDrive 611
Параметры MD 30110 и MD 30220 устанавливаются согласно документации.

Что еще нужно установить в конфигурации, чтобы можно было двигаться дальше?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт фев 17, 2012 19:53 
Не в сети
Написал больше чем Вы читали

Зарегистрирован: Сб фев 04, 2006 10:52
Сообщения: 1273
Откуда: Москва
http://iadt.siemens.ru/assets/files/inf ... 2_free.pdf
По данной ссылке можно скачать документацию по вводу в эксплуатацию системы 802D. Желательно еще иметь тулбокс соответствующей версии, так как стандартные циклы все равно придется откуда то брать. Имеет очень большой смысл сохранить текущую PLC программу. Для этого нужна программа ProgramingTool PLC802.
По вашему описанию как раз 11240=5.
Ошибки на этом этапе вполне нормальны, так как нужно настраивать еще килограмм параметров. Например нужно описать сколько и каких у Вас осей. Далее какие оси геометрические и т.д.
В общем сначала прочитайте документацию, ну а если будут вопросы, тогда пишите.
Лучше же конечно же найти архивы от этого станка, например запросив их у изготовителя станка.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Сб фев 18, 2012 21:31 
Не в сети

Зарегистрирован: Пт фев 17, 2012 16:01
Сообщения: 6
Ну прежде чем забивать килограмм параметров мы попытались восстановить все из архива. PCU понятно перезагрузилось раз 5 и загрузка вывалилась на ошибке 0х481. Производители железа сказали что у нас или шнурок неправильный или прошивка чужая. По поводу восстановления так же отослали к документации.
Вывалилась загрузка как раз на приводах. Досконально не помню, но в названии было "_DRV_".
Оси восстановились. По крайней мере Y стал шпинделем.

А можно у вас еще общую методу запуска токарного станка попросить. Может мы что-то пропустили...

ЗЫ Документацию читаем. Наверное дочитаем, если нас производство в понедельник... Ну еще сутки есть.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Вс фев 19, 2012 15:51 
Не в сети

Зарегистрирован: Пт фев 17, 2012 16:01
Сообщения: 6
Нашел сообщение об ошибке:
"Поток ошибок при перед.чер.V.24
DG.DIR\MDDRV.DIR\DRV1.TEA OK
@@_N_ADRV_DP_MD_DRV1 Ошибка! Код: 0x481"

Загружали раза 3-4. Неизменный результат.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Вс фев 19, 2012 17:05 
Не в сети
Написал больше чем Вы читали

Зарегистрирован: Сб фев 04, 2006 10:52
Сообщения: 1273
Откуда: Москва
У вас данные приводов не стирались? Если привода сконфигурированы, то эта ошибка происходит при попытки доступа к приводам по Profibus.
Это мое мнение, по коду ошибки я ничего сказать не могу.
Если архивом Вы восстановили все машинные данные, а привода никто не перепрограммировал, то все должно работать.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн фев 20, 2012 7:17 
Не в сети

Зарегистрирован: Пт фев 17, 2012 16:01
Сообщения: 6
Данные приводов не стирались.
Но данные PCU до конца из архива и не восстановились (см.ошибку)

А так как теперь данные приходится поднастраивать ручками то привода работают только по очереди. Можем запустать два из трех :) Любые.

Вопрос в следующем: При установке параметра 11240 в 5 ProfiBus не работает в принципе. Даже РР не видит. При установке в 4 не можем настроить двух осевой привод как одноосевой.

1. Как настроить ProfiBus в данном случае?

2. Как настроить двухосевай привод как одноосевой?

3. Должен ли производитель железа класть в коробочку еще и архив мозгов станка?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн фев 20, 2012 11:16 
Не в сети
Написал больше чем Вы читали

Зарегистрирован: Сб фев 04, 2006 10:52
Сообщения: 1273
Откуда: Москва
Как я понял из разговора с Торопцевым Михаилом, у вас версия системы 1.2. В этой версии штатно нельзя было использовать конфигурацию с 3-мя одноосевыми модулями. Эта возможность появилась позднее. Наверное для того чтобы это было возможно на вашей версии системы, нужно загрузить какой-то спец. файл. К сожалению, я уже не помню подробностей, так как с такой версией сталкивался очень давно.
Если физически модули одноосевые, то использовать варианты с двухосевыми модулями не получится. Надежда на тех. поддержку и немецких коллег в Германии.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн фев 20, 2012 11:38 
Не в сети

Зарегистрирован: Пт фев 17, 2012 16:01
Сообщения: 6
Вчера я почитал документацию на 611UE. Сегодня дошел до станка, и увидел, что модули, судя по количеству разъемов на морде, двухосевые все, включая привод. На каждом висит по одному мотору.
Но конфигурятся нормально они лишь когда к ним обращаешься как к одноосевым.
Если мы, например ставим 11240 = 4, и пытаемся обратиться к осям по адресу и приводам "А", то PCU привода видит, но он их вечно ждет. Хотя все его характеристики читает (температуру движка и пр.).

Может мы Вам чего-то не договариваем по незнанию. Вы спрашивайте, мы еще раз к станку сбегаем, слянем.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Ср фев 22, 2012 15:46 
Не в сети

Зарегистрирован: Пт фев 17, 2012 16:01
Сообщения: 6
Все дело оказалость в файле transfer.mmc, который Вы нам прислали. Спасибо. После него конфигурация залилась полностью. Станок еще не пошел, но тут мы уже смотрим все ли у него корректно по цепям. Если интересно после праздника отпишусь.


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
 [ Сообщений: 9 ] 

Часовой пояс: UTC + 3 часа


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 2


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения

Перейти:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group