SIEMENS, DF&PD

Предыдущее посещение: Пт июл 08, 2016 7:47 Текущее время: Пт июл 08, 2016 7:47

Часовой пояс: UTC + 3 часа




 [ Сообщений: 14 ] 
Автор Сообщение
 Заголовок сообщения: Проблема с контроллером S7 417-4H
СообщениеДобавлено: Пн дек 06, 2010 13:33 
Не в сети

Зарегистрирован: Вс ноя 14, 2010 14:39
Сообщения: 4
Добрый день!
Резервируемая система 417-4Н (6ES7 417-4HL04-0AB0).
недели две назад столкнулись с проблемой все светодиоды на ПЛК (rack 1) моргали. программатором не конектится (MPI, Ind.Ethernet). хотя WinCC работает. решением было вытащить CPU из корзины или вытащить батарейки из блока питания. И включили ПЛК повторно через 2 минуты, как было посоветовано здесь же на форуме.
Вчера произошла аналогичная ситуация со вторым контроллером (rack 0).
внутренних ошибок в программе нет.
помогите пожалуйста.
заранее благодарен.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн дек 06, 2010 14:04 
Не в сети
Писатель со стажем

Зарегистрирован: Ср июн 17, 2009 9:39
Сообщения: 969
1. В свете последних событий проверьтесь на Стукнет - он как раз поражает подобные системы.
http://www.automation-drives.ru/forum/v ... hp?t=14276

То есть первым делом проверьте программатор на отсутствие Стукнета.
Затем подключитесь к контроллеру и проверьте отсутствие лишних команд в начале OB1, и ОВ35.
Отсутствие инородных DB8062, DB8063 и прочего согласно
http://www.symantec.com/connect/blogs/d ... infections

2. Если Стукнета не было, то надо сообщить все подробности о системе, в том числе возможность остановки всей системы.
Наличие бесперебойника, развязывающего трансформатора в цепях питания ~220 В.

Можно попробовать обновить прошивки на обоих процессорах - какая у вас ?
http://support.automation.siemens.com/W ... en/6741018

Привести буфер диагностики.
Подёргать модули синхронизации и оптические кабели, блоки питания.

В последнее время были сообщения у нас и на инофорумах о единовременном парном сдыхании процессоров в резервированных системах 417-4Н.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Вт дек 07, 2010 8:36 
Не в сети

Зарегистрирован: Вс ноя 14, 2010 14:39
Сообщения: 4
Цитата:
1. В свете последних событий проверьтесь на Стукнет - он как раз поражает подобные системы.
http://www.automation-drives.ru/forum/v ... hp?t=14276

То есть первым делом проверьте программатор на отсутствие Стукнета.
Затем подключитесь к контроллеру и проверьте отсутствие лишних команд в начале OB1, и ОВ35.
Отсутствие инородных DB8062, DB8063 и прочего согласно
http://www.symantec.com/connect/blogs/d ... infections

проверил программатор на наличие вирусов - нет, слил прогу с резервного контроллера вроде нет никаких инородных кодов.
Цитата:
Наличие бесперебойника, развязывающего трансформатора в цепях питания ~220 В.

бесперебойник правда байпасный
Цитата:
Можно попробовать обновить прошивки на обоих процессорах - какая у вас ?

firmware 4.0. а как прошить?
Цитата:
Подёргать модули синхронизации и оптические кабели, блоки питания.

все уже заменил (оптику, БП, карты, СР) кроме самого контроллера.
он все так же моргает.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Ср дек 08, 2010 6:54 
Не в сети
Это точно не человек

Зарегистрирован: Вт май 03, 2005 17:11
Сообщения: 3547
программа в ОЗУ (не во флеш)?

Есть ли возможность погонять пустым - залита только крнфиг и пустой ОВ1?

В свое время отправлял 414Н 4.0 с непонятным дефектом, но сходным с описанным поведением. У себя дефект не смог воспроизвести, но один раз при включении проскочило в диаг. буфере намеки на фокусы памяти. Я грешу на тиристорный эффект микросхем ОЗУ, но - это только гнеподтвержденная гипотеза. В общем, в итоге переписки, суппорт сказал - махнем, не глядя, но спросил серийники и номер партии. Потом, появилась новая прошивка, которая по косвенным признакам из приложенного описалова была порождена этим дефектам. Посмотри свежие прошивки на суппорте - возможно такой дефект уже починен.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Ср дек 08, 2010 7:13 
Не в сети

Зарегистрирован: Вс ноя 14, 2010 14:39
Сообщения: 4
Цитата:
программа в ОЗУ (не во флеш)?

SRAM64M...
Цитата:
Есть ли возможность погонять пустым - залита только крнфиг и пустой ОВ1?

он не конектиться, после включения в эл.сеть СТОП моргает сек 15 а потом снова "новогодняя елка". на тумблер START/STOP/MRES не реагирует.

пациент мертв?!


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Ср дек 08, 2010 16:03 
Не в сети
Это точно не человек

Зарегистрирован: Вт май 03, 2005 17:11
Сообщения: 3547
это состояние называют "Defective". В Принципе можно снять дамп и отправить на суппорт. Но для этого нужна флеш минимум 32Мб


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Чт дек 09, 2010 6:04 
Не в сети
Начинающий писатель

Зарегистрирован: Пн апр 03, 2006 4:29
Сообщения: 52
Откуда: Магнитогорск
Dulat писал(а):
он не конектиться, после включения в эл.сеть СТОП моргает сек 15 а потом снова "новогодняя елка". на тумблер START/STOP/MRES не реагирует. пациент мертв?!

Если он пустой (при отключении питания слетела прога из-за плохих батарей), то так и будет. Пустой/новый Н-контроллер после подачи питания нужно оставить минут на 10 - он проходит самотестирование. После этого загорится только СТОП - можно грузить хард и софт. Но перед этим желательно обновить прошивку. Для этого нужно взять Флэшку и записать прошивку на программаторе. Потом при выключенном питании вставить Флэшку в гнездо ЦПУ. Включить. Подождать, пока обновится оп. система. Выключить. Извлечь Флэшку. Повторить с резервным ЦПУ. Последние прошивки ищите на сайте Сименс


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Чт дек 09, 2010 6:38 
Не в сети

Зарегистрирован: Вс ноя 14, 2010 14:39
Сообщения: 4
DDD писал(а):
Dulat писал(а):
он не конектиться, после включения в эл.сеть СТОП моргает сек 15 а потом снова "новогодняя елка". на тумблер START/STOP/MRES не реагирует. пациент мертв?!

Если он пустой (при отключении питания слетела прога из-за плохих батарей), то так и будет. Пустой/новый Н-контроллер после подачи питания нужно оставить минут на 10 - он проходит самотестирование. После этого загорится только СТОП - можно грузить хард и софт. Но перед этим желательно обновить прошивку. Для этого нужно взять Флэшку и записать прошивку на программаторе. Потом при выключенном питании вставить Флэшку в гнездо ЦПУ. Включить. Подождать, пока обновится оп. система. Выключить. Извлечь Флэшку. Повторить с резервным ЦПУ. Последние прошивки ищите на сайте Сименс

уважаемый DDD "новогодняя елка" моргает 4-е сутки...


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Чт дек 09, 2010 7:49 
Не в сети
Начинающий писатель

Зарегистрирован: Пн апр 03, 2006 4:29
Сообщения: 52
Откуда: Магнитогорск
Попробуйте обновить прошивку. М.б. слетела о.с. Если не поможет, - тогда клиент сдох.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Чт дек 09, 2010 10:55 
Не в сети
Это точно не человек

Зарегистрирован: Вт май 03, 2005 17:11
Сообщения: 3547
Сможете найти флеш на 32Мб или больше?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Вт дек 21, 2010 11:26 
Не в сети
Известный Писатель

Зарегистрирован: Вт янв 17, 2006 9:08
Сообщения: 105
У меня такая проблема была, когдла в помещении где был контроллер стояла температура менее -25 С. Работать начинал когда отогревался


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Вт дек 21, 2010 11:27 
Не в сети
Известный Писатель

Зарегистрирован: Вт янв 17, 2006 9:08
Сообщения: 105
У меня такая проблема была, когдла в помещении где был контроллер стояла температура менее -25 С. Работать начинал когда отогревался


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Ср дек 22, 2010 7:24 
Не в сети
Новый писатель

Зарегистрирован: Пн окт 20, 2008 12:32
Сообщения: 28
Вчера была похожая проблема на 4142DP //
Мигали все светодиоды на ЦПУ , связи не быо . На выходных портах пропали все сигналы - по виду полностью слетела программа.
Попытались сбросить ошибки переключателями режимов reset stop rum , не реагируют ( у нас система старая еще ключ стоит)
Выключили питание. Установили переключателм контроллер в STOP . Включили питание , мигание прекратилось , появилась связь . Загрузили программу система заработала.
Предположительно проблема возникла из за сбоя в сети DP .


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Ср дек 22, 2010 18:45 
Не в сети
Это точно не человек

Зарегистрирован: Вт май 03, 2005 17:11
Сообщения: 3547
Я думаю, что для сообчества было бы полезно считывание и сохранения диагностического буфера. Единственно, что если Вы передергивали питание без батареек, это бесполезно, поскольку буфер будет сброшен. Хотя уточняющий вопрос: - у Вас батарейки стоят?


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
 [ Сообщений: 14 ] 

Часовой пояс: UTC + 3 часа


Кто сейчас на конференции

Сейчас этот форум просматривают: нет зарегистрированных пользователей и гости: 5


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения

Перейти:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group