SIEMENS, DF&PD

Предыдущее посещение: Чт июл 07, 2016 15:19 Текущее время: Чт июл 07, 2016 15:19

Часовой пояс: UTC + 3 часа




 [ Сообщений: 11 ] 
Автор Сообщение
 Заголовок сообщения: Проблема с приемом пакета на CP-341
СообщениеДобавлено: Пт ноя 21, 2014 15:57 
Не в сети

Зарегистрирован: Пт ноя 21, 2014 15:38
Сообщения: 5
Доброго времени суток.
Помогите решить проблемку:
Конфигурация - S7-317 2pn/dp+CP341 (TRU Master с ключом)+Moxa (TRU Slave+MB TCP мастер)+симулятор устройства MB TCP на ноуте

шлю запрос с CP на моксу, она принимает запрос и передает его на симулятор, симулятор отрабатывает и шлет на моксу ответ, в свою очередь мокса отсылает ответ на CP341, но CP ничего не принимает (на моксе лампочка отправки загорается, а на CP RxD нет).
В чем может быть причина, что еще можно покрутить? перепробовал практически все варианты в HW config на CP ничего не помогло.
Что происходит при передаче смотрю в мониторе моксы и по лампочкам.

Изображение


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт ноя 21, 2014 19:07 
Не в сети
Известный Писатель

Зарегистрирован: Пт июн 30, 2006 15:53
Сообщения: 265
Откуда: Краснодар
Лампочка приема по любому должна мигать при приеме. Проверьте провода на обрыв, распайку разъема, Какой режим обмена вы используете - полу- или полнодуплексный.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения: Re: Проблема с приемом пакета на CP-341
СообщениеДобавлено: Пт ноя 21, 2014 23:29 
Не в сети
Известный Писатель

Зарегистрирован: Пн окт 18, 2010 9:28
Сообщения: 158
Откуда: Казахстан
winice писал(а):
В чем может быть причина, что еще можно покрутить? перепробовал практически все варианты в HW config на CP ничего не помогло...

Смотрите выход STATUS функционального блока для приема P_RCV_RK, так же загляните в буффер ПЛК.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Сб ноя 22, 2014 13:54 
Не в сети
Ведущий специалист

Зарегистрирован: Вт янв 11, 2005 9:27
Сообщения: 5029
Откуда: SIEMENS I IA AS Москва
И посмотреть диагностический буфер СР


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Сб ноя 22, 2014 22:13 
Не в сети
Известный Писатель

Зарегистрирован: Ср апр 09, 2008 13:41
Сообщения: 417
Откуда: Питер
Поменять А с В местами.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн ноя 24, 2014 13:11 
Не в сети

Зарегистрирован: Пт ноя 21, 2014 15:38
Сообщения: 5
Извините, что не отвечал, от инета отлучили))
Спасибо за советы, но вот:
>>>Лампочка приема по любому должна мигать при приеме. Проверьте провода на обрыв, распайку разъема, Какой режим обмена вы используете - полу- или полнодуплексный.
Лампочка мигает только на TxD на RxD не мигает. На моксе отправка идет, это видно опять же по лампочке на моксе.
Провода целые т.к. полудуплекс по двум проводам. Если запрос уходит, то и провода должны быть в порядке.

>>>Смотрите выход STATUS функционального блока для приема P_RCV_RK, так же загляните в буффер ПЛК.
STATUS = 16#0000 ошибок нет и длинна приема 0 хотя в DB 30 слов, а приходит всего 10
В буфере сименса ошибок не наблюдается.

>>>Поменять А с В местами.
К чему может привести такие эксперименты? у меня вроде с полярностью все в порядке. 4й контакт A(-), 11й контакт B(+) (15 контактный разъем)

Попробовал изменить задержку на ответ симулятора на ноуте на 10 мс - тоже не помогло. С Operating Mode Selection with RS 485 включал в режиме


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн ноя 24, 2014 13:56 
Не в сети

Зарегистрирован: Пт ноя 21, 2014 15:38
Сообщения: 5
Лампочка RxD будет загораться в любом случае, даже если я в контроллере не пропишу блок P_RCV_RK?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пн ноя 24, 2014 15:50 
Не в сети

Зарегистрирован: Пт ноя 21, 2014 15:38
Сообщения: 5
Может не идти прием без подключенной GND? При том, что передача проходит нормально...


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Вт ноя 25, 2014 19:35 
Не в сети
Известный Писатель

Зарегистрирован: Ср апр 09, 2008 13:41
Сообщения: 417
Откуда: Питер
Цитата:
К чему может привести такие эксперименты? у меня вроде с полярностью все в порядке. 4й контакт A(-), 11й контакт B(+) (15 контактный разъем)


Не знаю какое обозначение выводов приёма передачи для 2-х проводного RS-485 на вашей мохе, но если опираться на даташиты большинства популярных драйверов rs-485, в понятия А и В (относительно CP-341) вкладываются прямо противоположные понятия. Стандартная грабля при подключении к СР сименса всяких тензоэмов-овенов.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Вт ноя 25, 2014 22:40 
Не в сети
Известный Писатель

Зарегистрирован: Пт июн 30, 2006 15:53
Сообщения: 265
Откуда: Краснодар
Лампочка будет RxD загораться независимо от прописывания блоков. Это просто индикатор электрической активности в приемном канале. При перепутанной полярности тоже будет мигать лампочка, только вместо осмысленного пакета получите кашу во входном пакете. Попробуйте подключить землю, хуже не будет.
Какая скорость порта используется на Мохе?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Чт ноя 27, 2014 16:24 
Не в сети

Зарегистрирован: Пт ноя 21, 2014 15:38
Сообщения: 5
Всем спасибо, разобрался.
На самой моксе 5 контактов, и ниодной подписи. Я минусы с разных пар использовал. переключил на другую и поменял разьем и все заработало.


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
 [ Сообщений: 11 ] 

Часовой пояс: UTC + 3 часа


Кто сейчас на конференции

Сейчас этот форум просматривают: frokons, Google [Bot] и гости: 4


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения

Перейти:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group