SIEMENS, DF&PD

Предыдущее посещение: Чт июл 07, 2016 15:13 Текущее время: Чт июл 07, 2016 15:13

Часовой пояс: UTC + 3 часа




 [ Сообщений: 160 ]  На страницу Пред.  1, 2, 3, 4, 5, 6, 7, 8  След.
Автор Сообщение
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 8:29 
Не в сети
Известный Писатель

Зарегистрирован: Чт апр 04, 2013 12:50
Сообщения: 102
Откуда: Каменск-Шахтинский
Роман33 писал(а):
Если сумеете опросить через ОРС то и с контроллером свяжите.(и проверьте кабель,которым с ОРС работать будете)

Не вяжется чего-то... "Value=Bad" пишет всё время...
Modbus Tester 2.0.5 подключал - тот модуль видит.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 8:54 
Не в сети
Известный Писатель

Зарегистрирован: Ср сен 16, 2009 14:48
Сообщения: 457
Откуда: Владимирская губерния
Кабель то у Вас точно прямой?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 9:01 
Не в сети
Известный Писатель

Зарегистрирован: Чт апр 04, 2013 12:50
Сообщения: 102
Откуда: Каменск-Шахтинский
Роман33 писал(а):
Кабель то у Вас точно прямой?

Да -- взяли уже другой, на нём заводская бирка есть: "2-2, 3-3, 5-5, 7-7".
Поставил уже даже Lectus OPC,но бесполезно: "Ошибка соединения".


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 9:05 
Не в сети
Известный Писатель

Зарегистрирован: Ср сен 16, 2009 14:48
Сообщения: 457
Откуда: Владимирская губерния
Вот буквально полчаса назад связывался этим ОРС с китайским приводом,все прекрасно работало.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 9:14 
Не в сети
Известный Писатель

Зарегистрирован: Чт апр 04, 2013 12:50
Сообщения: 102
Откуда: Каменск-Шахтинский
Вроде всё правильно настроил:

Изображение


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 9:18 
Не в сети
Известный Писатель

Зарегистрирован: Ср сен 16, 2009 14:48
Сообщения: 457
Откуда: Владимирская губерния
Я имел ввиду ОРС который Вам отправил.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 9:27 
Не в сети
Известный Писатель

Зарегистрирован: Ср сен 16, 2009 14:48
Сообщения: 457
Откуда: Владимирская губерния
Попробуйте такие настройки
http://i024.radikal.ru/1403/e5/caaf6f8bf9af.png
Естественно все другие программы которые могут использовать СОМ-порт должны быть закрыты.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 9:30 
Не в сети
Известный Писатель

Зарегистрирован: Чт апр 04, 2013 12:50
Сообщения: 102
Откуда: Каменск-Шахтинский
Правильно ли всё?

Изображение


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 9:36 
Не в сети
Известный Писатель

Зарегистрирован: Ср сен 16, 2009 14:48
Сообщения: 457
Откуда: Владимирская губерния
Проверяйте все регистры,там же можно тип сменить,а не только 4-ххххх.
Модбас-тестер какой тип регистров видит или там не посмотришь?
И в симуляции сигнала поставьте User Read/Write,у Вас Ramp стоит.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 9:45 
Не в сети
Известный Писатель

Зарегистрирован: Чт апр 04, 2013 12:50
Сообщения: 102
Откуда: Каменск-Шахтинский
Роман33 писал(а):
И в симуляции сигнала поставьте User Read/Write,у Вас Ramp стоит.

исправил.

Роман33 писал(а):
Проверяйте все регистры,там же можно тип сменить,а не только 4-ххххх.
Модбас-тестер какой тип регистров видит или там не посмотришь?

всё перепробовал... ноль.

Вот модбас-тэстер:
Изображение


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 9:53 
Не в сети
Известный Писатель

Зарегистрирован: Ср сен 16, 2009 14:48
Сообщения: 457
Откуда: Владимирская губерния
Что то не очень понятно ,что Вы там читаете. Попробуйте с Тестера функцию 03h Read Holding Registers. Переключите вид в десятичный,удобнее же будет.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 10:26 
Не в сети
Известный Писатель

Зарегистрирован: Чт апр 04, 2013 12:50
Сообщения: 102
Откуда: Каменск-Шахтинский
Роман33 писал(а):
Переключите вид в десятичный,удобнее же будет.


Как?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 10:29 
Не в сети
Известный Писатель

Зарегистрирован: Ср сен 16, 2009 14:48
Сообщения: 457
Откуда: Владимирская губерния
Ну вроде на картинке Display as или это не то?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 10:33 
Не в сети
Известный Писатель

Зарегистрирован: Чт апр 04, 2013 12:50
Сообщения: 102
Откуда: Каменск-Шахтинский
Роман33 писал(а):
Ну вроде на картинке Display as или это не то?

да нет,там вроде типы принимаемой переменной (word, byte, integer, ...)

Запустил Modbus Monitor. С CPU раз в секунду шлётся посылка 97 FF 9D FF FD 53 EE 00. Видимо обращается к модулю.


Последний раз редактировалось askaev Пт мар 21, 2014 10:35, всего редактировалось 1 раз.

Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 10:34 
Не в сети
Известный Писатель

Зарегистрирован: Ср сен 16, 2009 14:48
Сообщения: 457
Откуда: Владимирская губерния
Судя по картинке Вы читаете 49 и 119 регистры,а их по моему и в руководстве на модуль нет. Если в десятичном виде не записывается, то 365 это 16D и длину поставьте 4,у Вас там 2 стоит.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 10:37 
Не в сети
Известный Писатель

Зарегистрирован: Чт апр 04, 2013 12:50
Сообщения: 102
Откуда: Каменск-Шахтинский
Роман33 писал(а):
Судя по картинке Вы читаете 49 и 119 регистры,а их по моему и в руководстве на модуль нет. Если в десятичном виде не записывается, то 365 это 16D и длину поставьте 4,у Вас там 2 стоит.

365 - это измеренное значение 1-го канала mds ai-8ui, а у меня сейчас подключен овен мв110-8ас. Там регистр 50 - адрес устройства. Пытаюсь хоть его считать.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 10:55 
Не в сети
Известный Писатель

Зарегистрирован: Ср сен 16, 2009 14:48
Сообщения: 457
Откуда: Владимирская губерния
Вы пытайтесь все таки с CPU модуль Ваш прочитать,создайте массив из двух слов,и пытайтесь прочитать хотя бы один канал. Т.е. DATA_ADDR 400365; DATA_LEN 2.


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 14:12 
Не в сети
Известный Писатель

Зарегистрирован: Чт апр 04, 2013 12:50
Сообщения: 102
Откуда: Каменск-Шахтинский
Роман33 писал(а):
Вы пытайтесь все таки с CPU модуль Ваш прочитать,создайте массив из двух слов,и пытайтесь прочитать хотя бы один канал. Т.е. DATA_ADDR 400365; DATA_LEN 2.


Т.к у меня подключен ОВЕН МВ110, то сделал DATA_ADDR 40050; DATA_LEN 1.
--- Не работает.

Для чего на плате выводы "ТА и "ТВ"?:
Изображение
если соединить ТА с T/RA, a TB c T/RB, то мигает только индикатор TxD.
если же отсоединить "ТА и "ТВ", и RS485 подсоединить только к T/RA и T/RB, то синхронно мигают оба -- и TxD и RxD.
Почему так?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 14:22 
Не в сети
Известный Писатель

Зарегистрирован: Ср сен 16, 2009 14:48
Сообщения: 457
Откуда: Владимирская губерния
О какой плате речь то идет?


Вернуться к началу
 Профиль  
 
 Заголовок сообщения:
СообщениеДобавлено: Пт мар 21, 2014 14:45 
Не в сети
Известный Писатель

Зарегистрирован: Чт апр 04, 2013 12:50
Сообщения: 102
Откуда: Каменск-Шахтинский
Роман33 писал(а):
О какой плате речь то идет?

CB1241

хотя и на модуле CM1241 вроде те же контакты...


Вернуться к началу
 Профиль  
 
Показать сообщения за:  Поле сортировки  
 [ Сообщений: 160 ]  На страницу Пред.  1, 2, 3, 4, 5, 6, 7, 8  След.

Часовой пояс: UTC + 3 часа


Кто сейчас на конференции

Сейчас этот форум просматривают: relline и гости: 1


Вы не можете начинать темы
Вы не можете отвечать на сообщения
Вы не можете редактировать свои сообщения
Вы не можете удалять свои сообщения

Перейти:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group